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CHAPTER 1

3D Analyst

The ArcView® 3D Analyst™ adds many powerful capabilities to your
desktop GIS. Through tutorials and step-by-step examples, this book will
show you how to analyze and visualize surface data, not only through the
interface tools it provides, but through its extensions to the Avenue™
scripting language, which allow you to create powerful custom
applications.
The 3D Analyst enables you to perform a wide range of activities:

~ « Create realistic surface models from multiple input sources.
* Determine height at any location on a surface.

* Find what is visible from an observation point.

* Calculate the volumetric difference between two surfaces.

Work with 3D vector features to make realistic models of the 3D world.
Visualize your data in 3D.
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What you can do with the 3D Analyst
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continuous data, like terrain elevation or tem e gradient. 3D vector features, where

X, Y, and Z coordinates are stored for every vertex, let you capture and represent

geographic features precisely. Analytic operators and 3D visualization tools tie these and
the rest of ArcView GIS software’s capabilities together into one integrated, easy-to-use
system.

Surfaces can be created from a wide variety of data sources. You can make grids by
importing USGS DEMs, DTED files, raw ASCII files, or one of many image formats. You
can also create grids from point data using interpolators such as IDW, spline, or kriging.
TINs can be created by triangulating features represented by points, lines, and polygons
or from grids. You can even modify your TINs by adding new data to them.

With these surfaces the 3D Analyst can create spot heights, profiles, contours, viewsheds
steepest paths, and more. This new information, produced from surface analysis
functions, can be used on its own or be fed back into the GIS to be modeled with other
spatial data and operators.

»

Lines of steepest path overlaid on a hilishaded surface reveal flow patterns.

In addition to creating and analyzing surfaces the 3D Analyst is a powerful visualization
tool for creating 3D perspective displays. You can pack more information into a
perspective display, and a perspective is easier for people to interpret.

On the left is the footprint of a coi
but little else. On the right is a 3D
what’s already there.
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On the left is the footprint of a construction project. It shows how much area the project will take up,
but little else. On the right is a 3D view of the site. It shows how it will actually look in relationship fo
what'’s already there.

The 3D Analyst is a valuable tool even when the only data available is 2D. Attributes of
thematic data can be used for height, facilitating the creation of 3D block diagrams or
choropleth maps.

State counties extruded by population. Counties are differentiated by color and population is
indicated by height.

Many of the tools used for display and query in the view document also work in 3D.
Themes are symbolized in the same fashion as in views. Tools for identifying and
selecting features also work the same. So you get up to speed quickly, without having to
learn a lot of new concepts.

When displaying data in the 3D environment, not only can you pan and zoom like in a
View, but also interactively tilt and rotate the data to change the viewing perspective.
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Name | Braci

3D Globe with transparent ocean. The database record for a feature selected from the display is
also listed.

Learning the 3D Analyst

The more you know about ArcView, the better prepared you’ll be to use the 3D Analyst.
We’ve assumed that you’re already familiar with ArcView GIS and that you have at least
worked through the ArcView Quick Start Guide and spent some time exploring the
software. (If you haven’t done so already, you should read Using ArcView GIS to
familiarize yourself with the ArcView GIS user interface and “out of the box” capabilities.)

What to read next

Chapter 2 of this book is a tutorial. In it, you can learn how to visualize data in 3D, how to
create surface models, and how to perform a number of analytic tasks on surfaces. After
reading Chapter 2, you’ll be able to perform basic tasks with the software and be ready to
master the advanced topics presented in the rest of the book.

How to get online help

To find out what a butt

*  Move the cursor over |
status bar.

To get help about a but

1. Click the Help button |

2. Click the button, tool,

To get help about a dia
*  Press the F1 key on yc

To use the ArcView Gl¢
1. From the Help menu, (

2. Click the Contents tab

To search the ArcView
1. From the Help menu, «

2. Click the Find tab.

Getting technical support

Please see the product regi:
at the ‘Obtaining technical

Visit ESRI on the Web

Find out everything you w:
ESRI’s Web home page at
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How to get online help

To find out what a button, tool, or menu choice does

« Move the cursor over it but do not select it. A short description will appear in the
status bar.

To get help about a button, tool, or menu choice

1. Click the Help button [

2. Click the button, tool, or menu choice you want to get help about.

To get help about a dialog box ,
*  Press the F1 key on your keyboard when the dialog is displayed.

To use the ArcView GIS help
1. From the Help menu, choose Help Topics.
2. Click the Contents tab or the index tab.

abase record for a feature selected from the display is

To search the ArcView GIS help for a particular word
1. From the Help menu, choose Help Topics.

s better prepared you’ll be to use the 3D Analyst. 2. Click the Find tab.

iliar with ArcView GIS and that you have at least
rt Guide and spent some time exploring the

1y, you should read Using ArcView GIS to

IS user interface and “out of the box” capabilities.)

Getting technical support from ESRI

Please see the product registration and support card that came with ArcView GIS, or look
-at the ‘Obtaining technical support’ section of the ArcView GIS online help.

Visit ESRI on the Web

you can learn how to visualize data in 3D, how to
tma nut.nber of analytic tasks on surfaces. After
orm basic tasks with the software and be ready to

the rest of the book. Find out everything you want to know about ESRI® software, data, and services. Visit

ESRI’s Web home page at www.esri.com.
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This chapter presents five step-by-step exercises, beginning with simple
display and query tasks in 3D and progressing to more complex analysis
and visualization. These present just the basics. You’ll be able to learn more
about these topics in the other chapters of this book and in the ArcView GIS
online help.

Before you start this tutorial, you should already have gone through the
ArcView Quick Start and should already know basic ArcView GIS
terminology and interface concepts. You should also be familiar with the
L_. analysis capabilities of ArcView GIS.

» Exercise 1: Viewing in perspective

* Exercise 2: Creating and populating a 3D scene -

Exercise 3: Creating 3D shapes
— * Exercise 4: Surface analysis

Exercise 5: Advanced visualization
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Exercise 1: Viewing in perspective

3D scenes are used like ArcView views to display and query geographic data. In this
exercise, you’ll view features from different angles and learn how to identify and select
them.

To open the project for this exercise

1. Choose Open Project from the File menu. ,
2. In the Open Project dialog, navigate to the Avtutor\3d directory.
3. Double-click on tutorl.apr.

When the project has opened, you’ll see two windows that belong to a 3D scene. One
window is a 3D scene Table of Contents named 3D Scenel. Like a view’s Table of
Contents, it lists the legends for the themes in the scene. The second window is a 3D
scene viewer named 3D Scenel-Viewerl, which is used to display the themes in a 3D
scene. You can open up as many viewers as you need and move them outside the
ArcView application window.

The 3D scene in this exercise has two themes: terrain and buildings.

To navigate a scene

1. With the viewer Navigate tool il sclected, and the cursor in the display area, press
the left mouse button and move the mouse in any direction to rotate the data.
Depending on how long it takes to redraw a theme when you’re navigating, the
software may switch to a simpler version of the theme, like a 3D bounding box, to
improve performance while interacting. .

Press the right mouse butt

2.
3. Press both left and right n
and move the mouse to p?
4 Press the Zoom to Full Ex
Press the Rotate button ]
ESC key on your keyboart
application window, to hal
To identify features
1. Make both the Bldg.shp a
active theme for the Identi
contained in active theme:
2. Choose the Identify tool E
3. Click over one of the build
providing information ab«
4. Click on other buildings t
Click on the terrain model
You can identify while in navig
holding down the SHIFT key ¢
terrain model.
To select features
1. Choose the Select Feature
2. Make sure the Bldg.shp tt
3. Click over one of the buil
4. Click over another buildit
5. - While holding down the £
6. Press the Open Theme Tal
records of the selected bu
7. Using the table Select too!

corresponding buildings v
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h

Press the right mouse button and move the mouse up and down to zoom in and out.

Press both left and right mouse buttons (or the middle button on a 3-button mouse)
and move the mouse to pan.

Press the Zoom to Full Extent button [ in the viewer to reset the perspective.

3 A +. s 11 Diye, +h
Press the Rotate button il to have the scene spin around automatically. Press the

ESC key on your keyboard, or the Stop button on the bottom right of the ArcView
application window, to halt the rotation.

To identify features

1.

4.

5.

Make both the Bldg.'shp and Dtm_tin themes active. You must have at least one
active theme for the Identify tool to be enabled. It will only report on features
contained in active themes. '

Choose the Identify tool il on the viewer.

Click over one of the buildings with the cursor. The Identify window will come up
providing information about the building you pointed to.

Click on other buildings to see their records.

Click on the terrain model to get information about it.

You can identify while in navigate mode without having to switch to the Identify tool by
holding down the SHIFT key on the keyboard then clicking on one of the buildings or the

terrain model.

To select features

1. Choose the Select Features tool fjjjj-

2. Make sure the Bldg.shp theme is active.

3. Click over one of the buildings with the cursor. It will become highlighted.

4. Click over another building; the selection will switch.

5. 'While holding down the SHIFT key, click on a building. This adds to the selection.
6. Press the Open Theme Table button [} Scroll through the table to see that the

records of the selected buildings are also highlighted.

Using the table Select tool fjjjj, select some of the records in the table. The
corresponding buildings will be highlighted in the viewer.
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IN LbyeT pfpnic TH /iew

To add data to the 3D scel

To define 3D scene properties
1. Choose Properties from the 3D Scene menu. L. Press the Add Theme but!
<. Fressihe Background color Select... button, choose a dark blue, and press OK on the 2. Navigate to the avtutor\3
Color Picker. 3. Set the Data Source Type:
3. Change the Vertical exaggeration factor to 1.5, then press OK. 4. Select and add brklinz.shy
5. Click the Zoom to Full E
. 6. Turn on all three themes f
The Brklinz.shp and Masspnt:

Exercise 2: Creating and populating a 3D scene

In this exercise you’ll learn how to create the 3D scene used in Exercise 1. To do this
you’ll open a new 3D scene, add themes to it, create a terrain model, and define
properties for buildings to display them in 3D.
"To open a new 3D scene document

1.

Make the project window active, then choose New Project from the File menu.
Choose ‘No’ if you're asked to save the project from Exercise 1.

From the File menu choose Extensions... then select the 3D Analyst and press OK.
Make the 3D Scenes icon at the left of the project window active. You may need
to scroll down the list of icons before you can see it.

Click New to open a new 3D scene.

their z values. One has mass P
breaklines, which are linear fe:
Perim.shp theme is the bounds
Perim.shp theme displays flat,

You’ll use these three themes t

To create a TIN theme of te
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2. Choose Create TIN From ]

3. In the Create new TIN dia
Themes scroll list. See hoy
the right.

4. Highlight the other two the
their default settings.

5. Press OK then provide a di

6. Choose Delete Themes fro
and Brklinz.shp themes fro
When asked, choose Yes tc

7. Turn on the TIN theme.

The Height source dropdown o1
the Brklinz.shp and Masspntz.s]
taken from the surface defined |

To see the buildings displayed i
theme to get the building base }
that base by a value equal to th
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To add data to the 3D scene

1. Press the Add Theme button &

2. Navigate to the avtutor\3d\site1 directory.

3. Set the Data Source Types to Feature Data Source.

------

Select and add brklinz.shp, masspntz.shp, and perim.shp as themes.
Click the Zoom to Full Extent button g on the viewer.
Turn on all three themes for display.

o v op

The Brklinz.shp and Masspntz.shp themes contain 3D features and are displayed using
their z values. One has mass points with measured spot heights. The other contains
breaklines, which are linear features on the terrain such as roadsides and ridgelines. The
Perim.shp theme is the boundary for the study area. Because it’s a 2D feature, the
Perim.shp theme displays flat, under the other two themes.

You’ll-use these three themes to create a TIN-based terrain model.

To create a TIN theme of terrain

1. In addition to the Perim.shp theme which should already be active, make the
Masspntz.shp and Brklinz.shp themes active.

2. Choose Create TIN From Features in the Surface menu.

3. In the Create new TIN dialog, highlight the Perim.shp entry in the Active Feature
Themes scroll list. See how the default settings are listed for the theme in the fields to
the right.

4. Highlight the other two themes listed in the Active Feature Themes scroll list to see
their default settings.

5. Press OK then provide a directory and name the output TIN.

6. Choose Delete Themes from the Edit menu to remove the Perim.shp, Masspntz.shp,
and Brklinz.shp themes from the Table of Contents; they aren’t needed anymore.
When asked, choose Yes to All to delete all three themes.

7. Turn on the TIN theme.

The Height source dropdown on the Create New TIN dialog offers a Shape field for both
the Brklinz.shp and Masspntz.shp but not for Perim.shp. Heights for Perim.shp will be
taken from the surface defined by the mass points and breaklines.

To see the buildings displayed in 3D on top of the TIN, you have to tell the Bidg.shp
theme to get the building base heights from the TIN surface and to extrude them up from
that base by a value equal to their height.
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To display buildings in 3D 3. If you’re asked to save the pr

1. Press the Add Theme button, set the Data Source ’I’ypes to Feature Data Source, and
.~ navigate to the avtutor\3disitel directory

2. Add bldg.shp as a theme.

3. Draw the Bldg.shp theme. These are 2D features and will display flat, below the TIN.
4. Make the Bldg.shp theme active.
5
6
7

4. Navigate to the avtutor\3d di

You should see three themes: Wel
Wells.shp themes display below L
information.

From the Theme menu choose 3D Properties.

In the Assign base heights by panel select the Surface radio button.

In the Extrude features by value or expression panel press the Calculator button g,
located to the right of the scrollable edit box. .

8. Define the expression ‘[Stories] * 10" and press OK.
9. Set the Extrude by field to Adding to min z value.
10. Press OK on the 3D Properties dialog.

To change the color of the buildings

1. Double-click on the Bldg.shp theme legend in the Table of Contents to bring up its
Legend Editor.

2. Set the Legend Type to Unique Value and the Values Field to Owner.
Press Apply and dismiss the Legend Editor.

To create 3D points using an:
1. Make sure the Wells.shp ther

4. Now go ahead and use the 3D scene properties to adjust the vertical exaggeration, 2. Choose Convert to 3D Shape:

change the background color, or reset the sun position. - 3. Set the Get Z values from drc

IN tAeT . (Mper & P e VIEW 4. From the dropdown list that ;
the wells.

Exercise 3: Creating 3D shapes 5
. In the dialog that asks what t
OK. The output shapefile will

When asked whether you’d li
7. Delete the 2D Wells.shp them
8. Draw the Wellsz1.shp theme.

As shown in Exercises 1 and 2, you can view 2D shapes in perspective by converting
them to 3D on the fly. The 3D properties you define are temporary and must be defined
again if you want to view these shapes in perspective in another project. If you’d like to
distribute the shapes and have them immediately viewable in 3D without ancillary data,
like a surface model, you’ll need to store the shapes as 3D entities, where height is
maintained as part of the feature geometry.

You may have trouble seeing the |
Feature height determines what ge
two features are at the same heigh
alleviate this, either turn off the di:
surface with the Offset heights op
menu.

In this exercise you’ll use both attribute information and a surface to provide heights.

To open the project for this exercise
1. Make the project window active.
2. Choose Open Project from the File menu.




st the Data Source Types to Feature Data Source, and
1 directory.

Chapter 2 Quick Start Tutorial 13

3. If you’re asked to save the project from the previous exercise, choose No.

4. Navigate to the avtutor\3d directory and open tutor3.apr.
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Wells.shp themes display below Dtm_tin because they are 2D themes without height
information.

To create 3D points using an attrlbuté representing height

1. Make sure the Wells.shp theme is active.

2. Choose Convert to 3D Shapefile from the Theme menu.

3. Set the Get Z values from dropdown choice to Attribute and press OK.
4

From the dropdown list that appears, select Gl_elev, the ground-level elevation of
the wells.

5. Inthe dialog that asks what to use for an output name, specify wellsz1.shp and press
OK. The output shapefile will be created.

6. When asked whether you’d like the shapefile added as a theme, answer Yes.
Delete the 2D Wells.shp theme.
8. Draw the Wellsz1.shp theme.

You may have trouble seeing the points because they’re the same height as the surface.
Feature height determines what gets drawn on top, not theme order as in views. When

two features are at the same height you can’t be assured you’ll see either very well. To
alleviate this, either turn off the display of Dtm_tin or raise the wells a few units above the

surface with the Offset heights option that’s in the 3D Properties dialog under the Theme
menu.
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To create 3D lines by overlaying features on a surface model

1.
2.
3.

4
5.
6.
7

Make the Roads.shp theme active.
Choose Convert to 3D Shapefile from the Theme menu.

Set the Get Z values from dropdown choice to Surface and press OK. When
prompted for a surface, select Dtm_tin.

Name the output roadsz1.shp and press OK.

‘When asked whether you’d like the shapefile added as a theme, answer Yes.
Delete the 2D Roads.shp theme. o
Turn on the display of the Roadsz1.shp theme.

This will interpolate height information for the roads from the Dtm_tin theme,
converting the 2D line features into 3D.

As with the wells, you may have trouble seeing the roads because they’re at the same
height as the surface and can be obscured by it. You can either turn off the display of
Dtm_tin or raise the roads a few units above the surface with the Offset heights option in
the 3D Properties dialog under the Theme menu.

You can also define 3D graphics with the cursor. Heights for the graphics are interpolated
off the active TIN or grid theme. There are tools for lines, points, and polygon
boundaries. These tools are found in the view document and enabled when a TIN or grid
theme is active.

To create 3D shapes interactively

1
2

© N oo oA

Make the Dtm_tin theme active.
Choose Copy Themes from the Edit menu.

Choose Close from the File menu. The 3D scene Table of Contents and its viewer will
automatically be dismissed.

Open a new view.

Choose Paste from the view Edit menu.

Make the Dtmn_tin theme active and make sure its display is on.
Select the Interpolate Line tool i from the toolbar.

Bring the cursor into the view window, over the TIN, and enter a polyline by
clicking the left mouse button. Single clicks add new vertices while a double click
ends the line. Add several lines, horizontal and vertical.

Choose Select All Graphics from the Edit menu.

10.

11.
12.

13.

14.

15.

Choose Show Symbol Wind
and set the color to light gre:

Choose Copy Gﬂphies unde
Go to the ArcView project w
previous 3D scene and press-

Choose Paste under the 3D :
3D scene.

Turn off the themes in the 31
drawn with 3D boxes around
selection handles.

Choose Delete Graphics und
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Exercise 4: Surface analysis

In this exercise you’ll learn how
contour a surface, how to perforr
graph. ’

To open the project for this ¢

1.

2
3
4.

Make the project window ac
Choose Open Project under t
If you’re asked to save a pro

Navigate to the avtutor\3d d

To query elevation, slope, an

1.
2.
3.

Make sure the Dtm_tin then
Go to the toolbar and select

Bring the cursor into the vie
left mouse button. An Identi
location in the left panel, an
panel.

Dismiss the Identify Results
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10. Choose Show Symbol Window from the Window menu. Go to the color palette panel

ive. and set the color to light green. Dismiss the color palette.
¢ from the Theme menu. 11. Choose Copy Grgphiés under the Edit menu.
lown choice to Surface and press OK. When 12. Go tf’ the ArcView project window and select the 3D Scenes icon. Highlight your
Ym_tin. previous 3D scene and press Open.
id press OK. 13. Choose Paste under the 3D scene Edit menu. This will paste the 3D graphics into the

' 3D scene.

the shapefile added as a them '

© answer Yes. 14. Turn off the themes in the 3D scene to see the graphics easier. Selected graphics are

Isz1.shp theme.
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3D.
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‘from the toolbar.

1dow, over the TIN, and enter a polyline by

agle clicks add new vertices while a double click
10rizontal and vertical.

he Edit menu.

S.

drawn with 3D boxes around them. These are the 3D scene equivalent of view
selection handles.

Choose Delete Graphics under the Edit menu.
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Exercise 4: Surface analysis

In this exercise you’ll learn how to query point based information from surfaces, how to
contour a surface, how to perform line of sight analysis, and how to create a profile

graph.

To open the project for this exercise

1.

2
3,
4

Make the project window active.
Choose Open Project under the File menu.
If you're asked to save a project from a previous exercise choose No.

Navigate to the avtutor\3d directory and open tutor4.apr.

To query elevation, slope, and aspect from TIN themes

1.
2.
3.

Make sure the Dtm_tin theme in the view Table of Contents is active.
Go to the toolbar and select the Identify tool i

Bring the cursor into the view window over the TIN and enter a point by clicking the
left mouse button. An Identify window will pop up listing the theme name and xy
location in the left panel, and the location’s elevation, slope, and aspect in the right
panel.

Dismiss the Identify Results window.
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Contours are lines that connect points of the same height.l They are frequently used on To create a profile grapl"\
maps to convey information about topography.-
Tocreatecontours
1. Choose Create Contours from the Surface menu. Profile from View1
) Vertical exaggeration 3.0 X
2. Accept the defaults and press OK. A new theme of contours will be added to the

\

e

view.

Elevation
IL_T__'I’

3. Turn on the Contours of Dtm_tin theme to see the resulting contour lines.

The Line of Sight tool determines what is visible between an observer and target and
whether the target itself is visible.

To perform line of sight analysis 1. Make sure the Dtm_fin them

1. Make sure the Dtm_tin theme is active. 2. Choose the Interpolate Line t

2. Click and hold the left mouse button over the Contour tool . This will expose the 3. Bring the cursor into the viev

Line of Sight tool [ that’s underneath it. Select the Line of Sight tool. clicking the left mouse butto:

3. Set the observer height offset to 20.0, accept the default of 0.0 for the target and the line.
press OK. 4. Open a new Layout.

4. With the cursor over the display of the Dtm_tin theme, press down the left mouse 5. Choose the Profile Graph too
button to position the observat?c!n point and while holding down the left button 6. With the cursor define a box .
move the cursor to a target position and release.

5. Do this for several lines. 7 Accept the defanlts listed in t

Th . .

A report indicating whether the target is visible is listed in the ArcView status bar at the aroi;:‘::::ng lglraflil sa grdo u][:l)ed ¢

bottom of the Application window. That portion along the line of sight that’s visible is aware that gooﬂ re?n, a; ¢ anf

drawn in green. The invisible portion is drawn in red. If the target is not visible, the first become inv aﬁ' 4 126 the grap

obstruction point will be included with a blue marker.

VN LT ~ 1w

The observer and target heights are set equal to the z value of the surface at their ExerCI se 5: Advanced visu aliz

locations plus the offsets you specified. To bring up the dialog to change the offset
settings, click the Line of Sight tool button, even if it’s currently active.

6. When finished choose Select All Graphics followed by Delete Graphics from the
Edit menu.

In this exercise you’ll learn two th
comprised of several data sets. Dis
relationships between themes. Sec
appearance of themes while intera
The Profile Graph tool will take selected 3D lines from either the graphics or the active faster when working with larger d:

theme and create a graph that shows the height measured along the lines.
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sints of the same height.' They are frequently used on

To create a profile graph
t topography.-

—the Surface menu
OK. A new theme of contours will be added to the

Profite from View1
\!em‘ul exaggeration 3.0 X

8‘\

tin theme to see the resulting contour lines.

what is visible between an observer and target and

sis
1. Make sure the Dtm_tin theme is active.

s active, 2. Choose the Interpolate Line tool .

button over the Contour tool . This will expose the

3. Bring the cursor into the view window, over the TIN, and enter a polyline by
derneath it. Select the Line of Sight tool.

clicking the left mouse button. Single clicks add new vertices, a double click ends

0 20.0, accept the default of 0.0 for the target and toe e
Open a new Layout.
y of the Dtm_tin theme, press down the left mouse Choose the Profile Graph tool -

ion point and while holding down the left button

tlon. end iy With the cursor define a box on the layout page.

A

Accept the defaults listed in the Profile Graph Properties dialog and press OK.

The resulting graph is a grouped collection of graphics. You can move the graphics
around, ungroup them, and change their properties as yon would other graph features. Be
aware that if you resize the graph the vertical exaggeration printed under the title will
become invalid.

VUit - fRwr Dl Lot

Exercise 5: Advanced visualization

et is visible is listed in the ArcView status bar at the
T'hat portion along the line of sight that’s visible is

1is drawn in red. If the target is not visible, the first
ith a blue marker.

set equal to the z value of the surface at their
;i To bring up the dialog to change the offset
it s .

on, even if it’s currently active. In this exercise you’ll learn two things. First, how to create a multilayered display
comprised of several data sets. Displays of this type are useful because they help you see
relationships between themes. Second, how to control rendering performance and
appearance of themes while interacting in a 3D scene. This can make the navigate tool
faster when working with larger data sets.

- Graphics followed by Delete Graphics from the

sted 3D lines from either the graphics or the active
the height measured along the lines.
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To open the first project for this exercise -

1. Make the project window active.

Choose Open Project under the File menu.

If you're asked to save a project from a previous exercise, choose No. ;

Navigate to the avtutor\3d directory and open tutor5a.apr.

Qs W

You’li see a 3D scene with themes representing utility lines, buildings, and an
orthophoto drawn in its viewer.

To create a mulitilayered display

1. Make sure the Chem_grd theme is active.

2. Choose 3D Properties under the Theme menu.

3. Inthe ‘Assign base heights by’ panel, to the right of the Surface choice, press the file
browser button £

4. Navigate to the avtutor\3d\site2 directory, make sure the Data Source Types is set to
Tin, and double click wtab_tin. :

Press OK on the 3D Properties dialog and turn on the display of Chem_grd.
Make the Wells.shp theme active.

To open the second project fo

1. Make the i)roject window acti
2. Under the File menu choose O
3. I you're asked to save a proje
4

In the ‘Assign base heights by’ panel, set the Surface to Dtm_tin.

5

6.

7.  Choose 3D Properties under the Theme menu.

8 ,
Navigate to the avtutor\3d dir

9

In the Extrusion panel, press the calculator button g
10. Create the expression ‘[Wtab_elev]’ and press OK. You’ll see a 3D scene comprised of
11. Set Extrude by to Using as absolute.

12. Press OK on the 3D Properties dialog then turn on the display of Wells.shp.

To control 3D theme rendering

1. Make sure the Navigate tool B
globe around. It’s probably ve;

You will see the wells displayed as vertical lines between two surfaces, the terrain and
2. With the Globe.shp theme actir

the water table. The terrain is represented by a digital orthophoto draped over a terrain
model. The water table surface has a grid of chemical contaminant levels draped over it.
While the wells are 2D point data, they have been extruded into vertical lines through the
3D Properties dialog.

Press the Advanced button on |

4. In the input field called ‘Use si
value 0.1.

5. Press OK on the Advanced 3D
Properties dialog.

6. Use the left mouse button to ro
you stop navigating it will turr

IN AT LA
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' panel, set the Surface to Dtm_tin.
1e calculator button [gj.

zlev]’ and press OK.

olute.

dialog then turn on the display of Wells.shp.

vertical lines between two surfaces, the terrain and
sented by a digital orthophoto draped over a terrain
1 grid of chemical contaminant levels draped over it.
1ey have been extruded into vertical lines through the

To open the second project for this exercise

1. Make the project window active.

2. Under the File menu choose Open Project.

3. If you're asked to save a project from a previous exercise, choose No.
4

Navigate to the avtutor\3d directory and open tutorSb.apr.
You’ll see a 3D scene comprised of a globe, with countries drawn in different colors.

To control 3D theme rendering performance

1. Make sure the Navigate tool i is active and use the left mouse button to spin the
globe around. It’s probably very sluggish.

2. VWith the Globe.shp theme active choose 3D Properties... from the Theme menu.
3. Press the Advanced button on the 3D Properties dialog.

4. In the input field called ‘Use simplified version if theme refresh exceeds:’ enter the
value 0.1.

5. Press OK on the Advanced 3D Properties dialog and then OK on the regular 3D
Properties dialog.

6. Use the left mouse button to rotate the globe. It will now turn into a 3D box. When
you stop navigating it will turn back into its full representation.

~ Pling THs
I Lyt e 7 T
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-

Now when you navigate, the simg
complex Globe.shp theme will tu
opposite occurs; the Catrybnd.shg

You can control how much time is allowed for a theme to try and render itself in full
detail before it switches to a simpler representation to boost navigation performance.
Note that this control is theme based, so the maximum time it will take for an entire 3D

scene to refresh one frame is the sum of the time allotted all themes comprising the scene.

To control theme representation during interaction

1. With the Globe.shp theme active choose 3D Properties... from the Theme menu.
2. Press the Advanced button on the 3D Properties dialog. |

3. Turn off the Draw theme when interacting option.

4. Press OK on both dialogs.
5

Make the Cntrybnd.shp theme active and choose 3D Properties from the Theme
menu.

Press the Advanced button on the 3D Properties dialog.
Turn on the Draw theme when interacting option.
Press OK on both dialogs.

Use the left mouse button to rotate the globe.

Y ® N oo

This tutorial has exposed you to j

R Tl .

remaining chapters in this book g

through better understanding, to t
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Now when you navigate, the simpler Cntrybnd.shp theme will draw but the more
complex Globe.shp theme will turn off altogether. When you stop navigating, the
opposite occurs; the Cntrybnd.shp will turn off and Globe.shp turns on.

This tutorial has exposed you to just some of the capabilities of the 3D Analyst. The
remaining chapters in this book go into greater detail on each topic and will enable you,
through betier understanding, to use the product more effectively.




