Making maps from templates

Opening a map template
Adding x,y data to a map
Drawing graphics on a map

Making a map that's accurate, informative, and nice to look at usually takes time, as you'll see in the next chapter. Sometimes, however, you have to make a professional-quality map on short notice. ArcMap comes with a number of templates to help you do this. In a template, the map elements you need (data frames, legend, title, north arrow, background color, and so on) are already in place. All you do is add data and the map is ready to print.

You may not even need to add data—many ArcMap templates already contain layers for the world and the United States. A single template may be all you need, or you may want to use a template as a basemap and add your own layers to it.

The LandscapeClassic template (left) has layout elements but no data. The WorldRobinson template (right) has countries, cities, rivers, and lakes in a Robinson projection.
Opening a map template

By default, every ArcMap document uses a template called the normal template. When you open a new document and switch to layout view, the layout page (also called the virtual page) is blank and has a single data frame. This is the appearance prescribed by the normal template.

In the course of making a map, you may add data to this data frame, resize it, insert more data frames, and add such elements as legends and scale bars. When you save the map, you save it not as a template but as a map document, or .mxd file. That way, the template does not change. Then, when you create a new ArcMap document, you start again with a blank page.

Rather than designing your own layout, you can open a custom template (that is, a template other than the normal template). Again, any changes you make are saved as a map document, so the template is not affected.

On the left is the PortraitClassic template. On the right are three maps that use it, each with different data. In map A, a title has been specified but the template is otherwise unchanged.
In map B, the legend, north arrow, and scale bar have been moved from their default positions.
In map C, the background color has been changed.
You can also create new templates. If you've made an arrangement of map elements and data frames (with or without data) that you want to use again, click Save As on the File menu and set the Save as type drop-down list to ArcMap templates. This will save the file with a .mxt extension. ArcMap custom templates are stored in the \Bin\Templates folder of your ArcGIS installation path (for example, C:\Program Files\ArcGIS\Bin\Templates). You can add your own templates to this folder or to any folder you choose. You can also modify existing templates. For more information, click the Contents tab in ArcGIS Desktop Help and navigate to ArcMap > Laying out and printing maps > Saving a map as a template.

**Exercise 18a**

It's early June 1999. As the information officer for the Philippine Atmospheric Geophysical and Astronomical Services Administration, you've been asked to talk to a group of journalists about Typhoon Maggie, also known as Etang.

Typhoon Etang was first spotted off the coast of Samar, an island in the east central part of the Philippines. It has since traveled northwest, and is currently about 250 kilometers off the northeast coast of Luzon, where the capital, Manila, is located. The typhoon will probably pass harmlessly north of Luzon, through open ocean, but should it strike land it could be devastating.

The presentation is scheduled for tomorrow, but you weren’t told about the briefing until today. Now it's 11:00 p.m. and you're trying to create a PowerPoint® slide presentation and still have time for a little sleep.

You want to show the path of the typhoon and its current location on a map of the country with rivers, populated places, and other useful geography. You'll use an ArcMap template for the basemap and draw the typhoon path yourself.

1. Start ArcMap. In the ArcMap dialog, click the option to use a template, then click OK. (If ArcMap is already running, click the File menu and click New.)
The New dialog opens. All the templates that come with ArcGIS can be found here. Instead of using one of these, however, you'll use a template that was specially created for this exercise.

2. Click the Browse button near the bottom of the dialog.

3. In the Open dialog, navigate to C:\GTKArcGIS\Chapter18. Click on ex18a.mxt and click Open.

The map opens in layout view. You see the continents of Asia and Australia with cities, rivers, lakes, and country boundaries. A graticule marks lines of latitude and longitude.
Although the map is based on a template (.mxt file), you are now working in a new map document (.mxd file). Any changes you make are made to the map document, not to the template—this is what keeps the template reusable. (If you wanted to modify the template itself—which in this case you don’t—you would click the File menu and click Open instead of New.)

With the entire map displayed, you can’t read the text and labels. This is because the page in the window (the virtual page) is smaller than the printed page would be. The Layout toolbar shows you the size of the virtual page relative to the actual page. (Your percentage may be different.)

4 On the Layout toolbar, click the Zoom to 100% button.

The layout zooms to actual size and you see the map at the resolution it would have on a printed page. You can no longer see the entire layout.

5 On the Layout toolbar (not the Tools toolbar), click the Pan tool.
6. Pan to the lower left corner of the map.

At 100 percent, map elements and text are legible, as they would be on the printed page.

7. On the Layout toolbar, click the Zoom Whole Page button.

The layout returns to full view.

The data frame shows all of Asia, but you are only interested in the Philippines. You'll use a bookmark to zoom in.

8. Click the View menu, point to Bookmarks, and click Philippines.
The map zooms in on the Philippines. The graticule, with its relatively wide intervals of 10 degrees, will not help the journalists describe the typhoon's location. You'll reduce the size of the intervals to make the map more informative.

9. In the table of contents, double-click on the Asia data frame to open the Data Frame Properties dialog. Click the Grids tab.


11. In the Reference System Properties dialog, click the Intervals tab.
72 Replace the X Axis Interval value of 10.000000 with 5 and the Y Axis Interval of 10.000000 with 5, as shown in the following graphic. Click OK, then click OK in the Data Frame Properties dialog.

73 On the Tools toolbar, click the Select Elements tool.

74 Click outside the virtual page to unselect the data frame.

The graticule is now divided into intervals of 5 degrees. Parallels and meridians are labeled on the layout, but the labels are too small to see when you are zoomed to the whole virtual page.

To add a graticule to a data frame that doesn’t have one, open the Data Frame Properties dialog, click the Grids tab, and click New Grid to start the Grids and Graticules wizard. (Graticules mark latitude and longitude coordinates. Measured grids mark projected coordinates.) Grids and graticules display only in layout view.

You now have your basemap. In the next exercise, you’ll display points that show Etang’s progress.

75 If you want to save your work, click the File menu and click Save As. Navigate to C:\GTKArcGIS\Chapter18\MyData. Rename the file my_ex18a.mxd and click Save.

76 If you are continuing with the next exercise, leave ArcMap open. Otherwise, click the File menu and click Exit. Click No if prompted to save your changes.
Adding x,y data to a map

As you know from the previous chapter, ArcMap can turn geographic information from a table into points on a map. When the information consists of street addresses, the process is fairly elaborate. If, however, you have a table of coordinate values (obtained from a Global Positioning System device or other source), ArcMap can create point data with little preparation.

A table of coordinates must contain two fields, one for the x-coordinate and one for the y-coordinate. The values may be in any geographic or projected coordinate system.

Exercise 18b

As part of your presentation to the press, you want to show the location, speed, and path of Typhoon Etang. You have been given a text file of latitude-longitude coordinates showing where the typhoon has been at different times. You’ll add this file to the map document and display the coordinates as points on the map.

1. Start ArcMap. In the ArcMap dialog, click the option to use an existing map. In the list of existing maps, double-click Browse for maps. (If ArcMap is already running, click the File menu and click Open.) Navigate to C:\GTKArcGIS\Chapter18. Click ex18b.mxd and click Open.

The map document opens in layout view and looks as it did at the end of the previous exercise.
You’ll add the file of latitude-longitude coordinates to the map document.

2. On the Standard toolbar, click the Add Data button.

3. In the Add Data dialog, navigate to C:\GTKArcGIS\Chapter18\Data. Click on latlong_etang.txt, as shown in the following graphic, and click Add.

The text file is added to the table of contents and displayed on the Source tab.

4. In the table of contents, right-click on latlong_etang.txt and click Open.
The table shows the typhoon's position and speed over the course of two days. Although latitude and longitude are measured in degrees, minutes, and seconds, the values in the table have been converted to decimal degrees so that ArcMap can store and process them efficiently. Decimal degrees represent minutes and seconds as fractions. For example, the value 30° 15' is 30.25 decimal degrees because 15 minutes is a quarter of a degree.

5 Close the table. In the table of contents, right-click on latlong_etang.txt and click Display XY Data.

ArcMap has correctly picked Longitude and Latitude as the fields containing coordinate values. Below this, in the Spatial Reference frame, the description is set to Unknown Coordinate System. If you knew which geographic coordinate system the latitude-longitude values were based on, you could click Edit and select it. Since you don't know, you'll let ArcMap assign a default geographic coordinate system. (At the scale of your map, the differences among most geographic coordinate systems are not noticeable.)
6 Click OK in the Display XY Data dialog to display the points on the map.

A layer called latlong_etang.txt Events is added to the table of contents. ("Events" is a technical term for points created from x, y coordinate values.) You'll give the layer a simpler name, then resymbolize the points with a symbol for typhoons.

7 In the table of contents, double-click the latlong_etang.txt Events layer. In the Layer Properties dialog, click the General tab.

8 Replace the layer name with Etang, as shown in the following graphic, then click OK.
9. In the table of contents, click the symbol for the Etang layer. The Symbol Selector dialog opens.

10. In the Symbol Selector, click More Symbols. Click Weather to load symbols from the Weather style.

11. Scroll to the bottom of the symbol list and click the Typhoon symbol. Change its size from 18 points to 4. Make sure that your dialog matches the following graphic, then click OK.

The points are resymbolized on the map.

In the next exercise, you'll draw a line along the typhoon's path.

12. If you want to save your work, click the File menu and click Save As. Navigate to C:\GTKArcGIS\Chapter18\MyData. Rename the file my_ex18b.mxd and click Save.

13. If you are continuing with the next exercise, leave ArcMap open. Otherwise, click the File menu and click Exit. Click No if prompted to save your changes.
Drawing graphics on a map

With the tools on the Draw toolbar, you can add graphics and text to a layout. You should wait to do this until you're satisfied with the display scale because graphics, unlike features, do not scale proportionately as you zoom in or out on data. A graphic box that encloses a feature at one display scale, for instance, may not enclose it at another.

**Exercise 18c**

Now that you have added the point locations of Typhoon Etang to your map, you'll draw the typhoon's path by connecting the symbols. Then you'll add some descriptive text and change the map title. When your map is ready, you'll export it in a format that PowerPoint supports so you can include it in your presentation.

1. Start ArcMap. In the ArcMap dialog, click the option to use an existing map. In the list of existing maps, double-click Browse for maps. (If ArcMap is already running, click the File menu and click Open.) Navigate to C:\GTKArcGIS\Chapter18. Click ex18c.mxd and click Open.

The map looks as it did at the end of the previous exercise. You'll zoom in on the layout to draw a line connecting the typhoon symbols.
2. On the Layout toolbar, click the Zoom In tool.

3. Drag a zoom rectangle corresponding to the red box in the following graphic.

The layout zooms in to the area of the storm's path.

4. On the Draw toolbar, click the drop-down arrow by the New Rectangle tool and click the New Curve tool.
5. Draw the typhoon path on the map. Start by clicking on the symbol farthest to the east. Click on each symbol to draw a line connecting them. Double-click on the last symbol to end the line. If you make a mistake, end the line, press the Delete key, and start again.

6. With the graphic selected, move the mouse pointer over the line and right-click. On the context menu, click Properties.

7. In the Properties dialog, click the Symbol tab if necessary. Click the color square. On the color palette, click Electron Gold, as shown in the following graphic. Click OK in the dialog.

The new color is applied to the line. (The palette shows additional colors because the Weather style is loaded.)
8 Click outside the data frame to unselect the line.

Now you'll add text to show the typhoon's time and speed at its last recorded position.

9 On the Tools toolbar, click the Identify tool.

10 Click the symbol at the last recorded position of Etang.

The time was 12 a.m. on June 5. The typhoon's speed was 170 kilometers per hour.
11 Close the Identify Results window. On the Draw toolbar, click the drop-down arrow by the New Text tool and click the Callout tool.

12 Click again on the same typhoon symbol. In the pop-up text box, type June 5 12:00 am - 170 kph and press the Enter key.

The text is added to the map and the text box is selected.

13 On the Draw toolbar, click the Font Size drop-down arrow and click 14.

14 Drag the callout text to the right of the typhoon symbol. Click outside the data frame to unselect the text.
Since the map is no longer a map of Asia, you need to change its title.

15 On the Layout toolbar, click the Zoom Whole Page button.

16 Double-click on the title Asia at the bottom of the map.

17 In the Properties dialog, on the Text tab, replace Asia with Path of Typhoon Etang, as shown in the following graphic. Click OK.

18 Click outside the page to unselect the title.
Finally, you'll export an image of the map in .emf format for your PowerPoint slide presentation. EMF files can be added to common Windows applications such as PowerPoint and Microsoft Word and resized without distortion. To learn more about the many graphic file formats ArcMap supports, click the Contents tab in ArcGIS Desktop Help and navigate to ArcMap > Laying out and printing maps > Exporting a map.

19 Click the File menu and click Export Map.

20 In the Export Map dialog, navigate to C:GTKArcGISChapter18\MyData. Click the Save as type drop-down arrow and click EMF (*.emf). Replace the default file name with etang, as shown in the following graphic, then click Save.

21 If you want to save your work, click the File menu and click Save As. Navigate to C:GTKArcGISChapter18\MyData. Rename the file my_ex18c.mxd and click Save.

22 If you are continuing to the next chapter, leave ArcMap open. Otherwise, click the File menu and click Exit. Click No if prompted to save your changes.