Projecting data in ArcMap

Projecting data on the fly
Defining a projection

Locations on the earth's surface are defined with reference to lines of latitude and longitude. Latitude lines, or parallels, run parallel to the equator and measure how far north or south you are of the equator. Longitude lines, or meridians, run from pole to pole and measure how far east or west you are of the prime meridian (the meridian that passes through Greenwich, England).

Latitude and longitude are measurements of angles, not of distances. Latitude is the angle between the point you are locating, the center of the earth, and the equator. Longitude is the angle between the prime meridian, the center of the earth, and the meridian on which the point you are locating lies. Because latitude and longitude are angles, their values are expressed in degrees, minutes, and seconds.
Why use angles instead of distances? Because as meridians converge toward the poles, the distance between them shrinks. At the equator, a degree of longitude is about 69 miles; at the 45th parallel, it's about 49 miles; at the north pole, it's zero. In other words, there is no constant distance value to represent the spacing between a pair of meridians. The angle between a pair of meridians, on the other hand, stays the same.

Starting from the equator, latitude values go to +90° at the north pole and to -90° at the south pole. Starting from the prime meridian, longitude values go to +180° eastward and to -180° westward. (The +180° and -180° meridians are the same.)

Latitude and longitude are the basis of a geographic coordinate system, a system that defines locations on the curved surface of the earth. Because different estimates have been made of the earth's shape and size, there are a number of different geographic coordinate systems in use. Although they are similar, the precise latitude-longitude coordinates assigned to locations vary from one system to the next.

Most geographic coordinate systems are based on the assumption that the earth is a spheroid. (A spheroid is to a sphere as an oval is to a circle.) This is a more accurate model because the earth bulges slightly at the equator and is flattened at the poles. Historically, several spheroids of varying dimensions have been calculated. (This picture greatly exaggerates the flattening, which is really only a fraction of a percent.)

Some geographic coordinate systems are based on the assumption that the earth is a sphere. This simple model is adequate for many purposes.
To make a map, the earth must be represented on a flat surface. This is accomplished by a mathematical operation called a map projection.

Locations on a map are defined with reference to a grid of intersecting straight lines. One set of lines runs parallel to a horizontal x-axis; the other set runs parallel to a vertical y-axis. The coordinates of any point are expressed as a distance value along the x-axis and a distance value along the y-axis (from the intersection of the axes).

A map projection flattens the earth. Locations on the earth are systematically assigned to new positions on the map. This can be done by many different methods (infinitely many, in fact).

A projected coordinate system, a system that defines locations on a flat map, is based on x,y coordinates. The x,y coordinates of any given point, such as Athens, depend on the map projection being used, the units of measure (meters, feet, or something else), and on where the map is centered. If Athens is made the center of the map, for example, its x,y coordinates will be 0,0. Thus, the number of possible projected coordinate systems is unlimited.

Since the world is more or less round and maps are flat, you can't go from one to the other without changing the properties of features on the surface. Every map projection distorts the spatial properties of shape, area, distance, or direction in some combination.
The Mercator projection preserves shape but distorts area. On the map, Greenland is much larger than Brazil, but on the earth it is smaller.

The Sinusoidal projection preserves area but distorts shape. The proportional sizes of Greenland and Brazil are correct, but not their shapes.

The Winkel Tripel projection balances distortion. No single property is faithfully preserved, but none is excessively distorted.

The Azimuthal Equidistant projection preserves true distance and direction from a single point (in this case, Athens) to all other locations on the map.

Your choice of map projection lets you control the type of distortion in a map for your area of interest. If you are mapping an area the size of a small country, and using an appropriate projection, the effects of distortion will be insignificant. If you are mapping the whole world, distortion will always be noticeable, but you can reduce or eliminate certain types of distortion according to your purpose.

For more information about coordinate systems and map projections, click the Contents tab in ArcGIS Desktop Help and navigate to Map Projections and ArcMap > Creating maps > About coordinate systems and map projections and ArcMap > Creating maps > Specifying a coordinate system.
Projecting data on the fly

Every spatial data set has a coordinate system. If it's a geographic coordinate system, its features store latitude-longitude values. If it's a projected coordinate system, its features store x,y values.

Besides storing feature coordinates, a data set contains other coordinate system information. The definition of a geographic coordinate system, for example, includes the dimensions of the sphere or spheroid it's based on and other details. The definition of a projected coordinate system includes the projection it's based on, the measurement units, and other details. Each projected coordinate system is also associated with a particular geographic coordinate system, since its x,y coordinates were at some time projected from a set of latitude-longitude coordinates.

You can find the coordinate system of a data set by clicking the metadata tab in ArcCatalog. You can also find it in ArcMap by clicking the Source tab of the Layer Properties dialog.

![World Countries (Generalized) shapefile](image)

This World Countries shapefile has a projected coordinate system. You also see the geographic coordinate system from which the projected coordinates were derived.

When you first add a layer to a data frame in ArcMap, it displays according to the coordinate values of its features—geographic or projected, as the case may be.

What happens when you add a second layer to the data frame? If it has the same coordinate system as the first layer, there's no problem. But what if its coordinate system is different? Since coordinates tell ArcMap where to draw features, there is a potential conflict.

ArcMap resolves this conflict automatically. You already know that a map projection is a math operation that changes geographic coordinates to projected coordinates. ArcMap knows the equations (forward and backward) for hundreds of projections. So when the second layer you add has a different coordinate system from the first, ArcMap changes Layer 2's coordinates to match Layer 1's. This process is called on-the-fly projection.
How does it work? Suppose you add a layer of world countries to a data frame. Say it’s in the Miller Cylindrical projected coordinate system. ArcMap stores the information about this coordinate system (and the geographic coordinate system it’s based on) as a property of the data frame. Suppose you next add a layer of world capitals in the Sinusoidal projected coordinate system. ArcMap checks the data frame properties and knows it can’t display this layer according to its Sinusoidal coordinates—it has to change them to Miller Cylindrical coordinates. To do this, it looks at the geographic coordinate system that the world capitals layer is based on, “unprojects” the Sinusoidal coordinates to latitude-longitude coordinates, and then projects these latitude-longitude coordinates to Miller Cylindrical coordinates. The result is that the capitals display in their correct relationship to the countries.

Now suppose you add a third layer of world rivers that is in a geographic coordinate system. The process is simpler. All ArcMap has to do is project the latitude-longitude coordinates to Miller Cylindrical coordinates. All three layers now occupy the same “coordinate space” and display in correct spatial alignment, even though the coordinates stored with the features are different for each layer.

The data frame adopts the coordinate system of the first layer added to it (in this case, Miller Cylindrical). Layers added subsequently are projected on the fly to this coordinate system.

You don’t have to use the coordinate system of the first layer you add—this is just the ArcMap default. You can assign any coordinate system you want to the data frame (even one that none of the layers have) and all layers will be projected to match it.

On-the-fly projection doesn’t change the feature coordinates of the data set on disk, or the data set’s coordinate system information. On-the-fly projection has effect only within a single data frame. If you were to add these same three layers to another
data frame in the same map document—but if you added the world capitals layer first—all the layers would display in the Sinusoidal projected coordinate system.

On-the-fly projection works best when layers are based on the same geographic coordinate system. If Layer 2 has a different geographic coordinate system from Layer 1, you'll get a message like this:

The message tells you that ArcMap can display the layer, but that the spatial alignment probably won't be just right. That's because ArcMap can't convert one geographic coordinate system to another without some help from you. Without that help, the data will be misaligned to the extent that the geographic coordinate systems differ from each other. This difference is usually too small to notice at the scale of a world map, or even a continental map. But if you are making a map that demands highly accurate feature positioning, or if you are geoprocessing the data, you will first want to convert one layer's geographic coordinate system to that of the other.

This operation is called a geographic coordinate system transformation (or a datum transformation). ArcMap supports it, but the process is not described in this book. For more information, click the Contents tab in ArcGIS Desktop Help and navigate to Map Projections > Geographic transformations.

**Exercise 13a**

You work for the U.S. Census Bureau and are creating a map of the United States that shows population change between 1990 and 2000. The map will have three data frames: one for the lower forty-eight states, one for Alaska, and one for Hawaii. The same shapefile of U.S. states (in a geographic coordinate system) will be used in all three data frames. You'll set a different projected coordinate system for each data frame and ArcMap will project the data on the fly.

Why use three data frames instead of just one? Showing all fifty states in the same data frame would mean including all the space that separates Hawaii and Alaska from the contiguous forty-eight states. You would have to zoom out so far that little states would be hard to see. By putting Alaska and Hawaii in their own data frames, however, you can zoom in on them and move them close to the other forty-eight states.
The United States drawn in a single data frame.

The United States drawn in three data frames. Alaska and Hawaii aren't shown in true proportion or at true distance from the lower forty-eight states, but that isn't important to the purpose of your map.

You will use three versions of the Albers Equal-Area Conic projection. This is an excellent general-purpose projection for areas in middle latitudes, especially those having an east-west orientation. It preserves the spatial property of area, which means that map features are displayed at their true proportional size. Shapes are only minimally distorted for an area the size of the United States.

1. Start ArcCatalog. In the ArcCatalog tree, double-click the connection to C:\GTKArcGIS. Double-click the Chapter13 folder. Double-click the Data folder.
There are two shapefiles: FastCities and States. Each has a corresponding layer file.
In this exercise, you'll use the States data. (You'll work with FastCities, which contains the fastest-growing city in each state, in the next exercise.)

1. In the catalog window, click on States.lyr and click the Preview tab.

The layer has been symbolized with a color ramp that shows population change.
The states, displayed according to their geographic coordinates, are distorted both in shape and area. The northern boundary of the United States appears to be a straight line, for instance, while Alaska looks stretched out. Montana seems to be roughly the same size as Texas, while in reality Texas is nearly twice as large.

2. Click the Preview drop-down arrow and click Table. Scroll to the right.

The table has 1990 and 2000 population figures for each state, as well as the population change in raw numbers and percentages. Every state grew during the decade. The layer is classified and symbolized on the PctChange attribute.

You'll confirm that the States shapefile has a geographic coordinate system.
1. In the catalog tree, click on States.shp. In the display, click the Metadata tab.

2. In the metadata window, click the Spatial tab. (If you don’t see the blue tabs in your metadata, click the Stylesheet drop-down arrow and click FGDC ESRI)

![Metadata Window]

The metadata shows a geographic coordinate system called GCS_North_American_1983. (This is a common geographic coordinate system for spatial data covering the United States. It is also called NAD83.)

Next, you'll start ArcMap and add the States layer file to a map document.

3. In the catalog tree, double-click ex13a.mxd.
ArcMap opens in layout view.

The map contains three empty data frames: Hawaii, Alaska, and Lower 48. Lower 48 is active. A title and legend have already been added to the map.

You’ll add the States layer to each data frame, zoom in appropriately, and apply map projections to the data frames.

1. Position the ArcCatalog and ArcMap windows so you can see the catalog tree and the ArcMap table of contents.

2. In the catalog tree, click States.lyr and drag it to the bottom of the ArcMap table of contents. Click the ArcMap title bar to bring ArcMap forward.
The layer is added to the table of contents and displays in the data frame. It looks as it did when you previewed it in ArcCatalog. You'll use a bookmark to zoom in to the lower forty-eight states.

3 Click the View menu, point to Bookmarks, and click Lower 48.
In the table of contents, double-click the Lower 48 data frame. In the Data Frame Properties dialog, click the Coordinate System tab.

By default, the data frame is set to the coordinate system of the first layer added to it. As you saw in step 5, that is GCS_North_American_1983.

In the Select a coordinate system box, click the plus sign next to Predefined.

Click the plus sign next to Projected Coordinate Systems, the plus sign next to Continental, then the plus sign next to North America.

A variety of projected coordinate systems for North American data are listed.
12 Click USA Contiguous Albers Equal Area Conic. (You can hold the mouse pointer over a name to see all of it.) The details of the projection appear in the Current coordinate system box. Make sure that your dialog matches the following graphic, then click OK.

The layer is projected on the fly. You'll use a bookmark to zoom in closer.

13 Click the View menu, point to Bookmarks, and click Lower 48 after Projection.

The states are displayed in the Albers Equal Area projection.

Now you'll copy the States layer to the other two data frames and set their coordinate system properties.
In the table of contents, right-click the States layer and click Copy. In the table of contents, right-click on the Hawaii data frame and click Paste Layer(s). Again in the table of contents, right-click on the Alaska data frame and click Paste Layer(s).

The States layer now displays in all three data frames.

In the table of contents, right-click the Alaska data frame and click Activate.

In the table of contents, double-click the Alaska data frame. In the Data Frame Properties dialog, click the Coordinate System tab if necessary.
As before, the data frame's coordinate system is set to GCS_North_American_1983. You'll set an Albers projection developed for Alaska.

18. In the Select a coordinate system box, click the plus sign next to Predefined, the plus sign next to Projected Coordinate Systems, the plus sign next to Continental, and the plus sign next to North America.

19. Click Alaska Albers Equal Area Conic. Make sure that your dialog matches the following graphic, then click OK.

![Data Frame Properties dialog]

The layer is projected on the fly. Notice that the lower forty-eight states are set at an odd angle. The projection minimizes distortion for Alaska, but other areas may be severely distorted. You won't show these areas in the data frame, so it doesn't matter.

20. Click the View menu, point to Bookmarks, and click Alaska.

![U.S. Population Growth 1900-2000 map]

21. In the table of contents, right-click the Hawaii data frame and click Activate.
Following the same steps you used for the other data frames, set the coordinate system of the Hawaii data frame to Hawaii Albers Equal Area Conic.

Click the View menu, point to Bookmarks, and click Hawaii.

Each of the three data frames now has a different projected coordinate system. (All use the Albers Equal Area Conic projection, but the projection settings are customized in each case to represent the area of interest as accurately as possible.)

If you want to save your work, click the File menu and click Save As. Navigate to C:\GTK\ArcGIS\Chapter13\MyData. Rename the file my_ex13a.mxd and click Save.

If you are continuing with the next exercise, minimize ArcMap by clicking on the left button in the upper right corner of the ArcMap application title bar. Otherwise, click the File menu and click Exit. Click No if prompted to save your changes.

In ArcCatalog, click the File menu and click Exit.
Defining a projection

Features in a data set never lose their coordinates, but the data set may not have the information that identifies its coordinate system. This can happen in particular with shapefiles, where the coordinate system information is stored as a separate file (with the extension .prj).

If you add a layer that is missing its coordinate system information, ArcMap will look at the feature coordinate values before proceeding. If it sees that all the values are between 0 and 180, it knows that the data is in a geographic coordinate system. It won’t know which one, but it will make a default assumption that enables it to display the layer with other layers already in the data frame. (The spatial alignment probably won’t be exact—just as when you add layers that have different geographic coordinate systems—but it will usually be acceptable for small-scale maps.)

If ArcMap sees that the coordinate values are big six- or seven-digit numbers, it knows that the data is in a projected coordinate system, but again, it doesn’t know which one. You’ll get this message:

![ArcMap warning message]

The message tells you that the layer can’t be projected on the fly. In other words, ArcMap can add the layer to the data frame, but it can’t change the layer’s coordinates to match the data frame’s coordinate system. The result is often a serious display problem, because very different sets of coordinates are trying to fit in the same map space. For example, if the data frame is set to a geographic coordinate system, the unknown layer probably won’t be visible (its projected coordinates are too far apart from latitude-longitude values). If the data frame is set to a projected coordinate system, the unknown layer may display, but will probably be seriously misaligned. Sometimes you get lucky, though. If the data frame happens to have the same projected coordinate system as the unknown layer, the data will line up correctly on its own.

If a data set is missing its coordinate system information, you should try to find out what it is. This may involve contacting the data provider or looking through files for supporting documentation. Once you know the coordinate system, you can assign it to the data set using ArcToolbox. This process is called defining a projection.
Exercise 13b
In this exercise, you’ll add a layer of the fastest-growing cities in each state to your map. From a colleague at the Census Bureau, you have acquired a shapefile of projected data along with a corresponding layer file. Unfortunately, the shapefile is missing its projection (.prj) file. This means that ArcMap can’t recognize the coordinate system and is unable to project the data on the fly.

After e-mailing your colleague, you have received the following reply:
“Sorry that the projection wasn’t defined. The FastCities shapefile is in the North America Lambert Conformal Conic projected coordinate system.”

You’ll add this coordinate system information to the shapefile with the ArcToolbox Define Projection tool.

1. Start ArcMap. In the ArcMap dialog, click the option to use an existing map. In the list of existing maps, double-click Browse for maps. (If ArcMap is already running and you minimized it, click on the ArcMap application on your taskbar to open it. Click the File menu and click Open.) Navigate to C:\GTKArcGIS\Chapter13. Click ex13b.mxd and click Open.

![Image of ArcMap window with a map of the United States]

The map opens in data view. The Lower 48 data frame is active.

2. On the Standard toolbar, click the Add Data button.
In the Add Data dialog, navigate to C:\GTKArcGIS\Chapter13\Data and click FastCities lyr, as shown in the following graphic. Click Add.

ArcMap warns you that the layer is missing spatial reference information.

(If you don’t see the warning, that’s okay. In your ArcGIS past, you may have come across the Warning dialog shown on page 337 and checked its Don’t warn me again ever box. If you would like coordinate system warnings to appear again, run the AdvancedArcMapSettings.exe executable file, which is located in the Utilities folder of your ArcGIS installation. On the Advanced ArcMap Settings dialog, click the Miscellaneous tab and uncheck Skip datum check.)

Click OK on the warning message.

ArcMap adds the FastCities layer. At first glance, things appear normal. If you take a closer look, though, you’ll see that some cities are lying outside the U.S. boundary.

The data frame’s current coordinate system is the USA Contiguous Albers Equal Area Conic (the one you set in the last exercise). From your colleague, you now know that the coordinate system of the FastCities layer is North America Lambert Conformal Conic. ArcMap, however, does not know this.

Because it couldn’t project the FastCities layer on the fly, ArcMap simply drew the features where their Lambert coordinates said they should go. But since these Lambert numbers were being plugged into Albers coordinate space, the locations are wrong. (It’s sort of like digging for buried treasure in the right place on the wrong island.)

As it happens, the Albers and Lambert coordinates for the United States are not hugely different; therefore, although the layers don’t align correctly, you can at least see them both together.
You'll zoom in for a closer look.

5. Click the View menu, point to Bookmarks, and click Southeast.

Among other problems, Myrtle Beach is in the ocean; Grand Rapids, Michigan, is in Indiana; Columbus, Ohio, is in Kentucky; and Nashville, Tennessee, is in Alabama.

Fortunately, you can use ArcToolbox to add the missing coordinate system information. Once you do that, ArcMap will be able to reproject the FastCities layer, and you'll see the cities display in their correct locations.

6. On the Standard toolbar, click the Show/Hide ArcToolbox Window button.

7. In the ArcToolbox Window, click the plus sign next to Data Management Tools. Click the plus sign next to Projections and Transformations.

8. Double-click the Define Projection tool to open it.
9. Click the Input Dataset or Feature Class drop-down arrow and click FastCities.lyr.

You see that the layer's coordinate system is Unknown.

10. Click the Properties button next to the Coordinate System box.

In the Spatial Reference Properties dialog, you can select from coordinate systems already defined by ArcGIS, import a coordinate system from another data set, or create an entirely new coordinate system. (You might do this, for example, if you were making a map of a newly discovered planet, since ArcGIS only has predefined coordinate systems for planets in our solar system.)

The Lambert Conformal Conic for North America, however, is defined by ArcGIS.
11 Click Select.

12 In the Browse for Coordinate System dialog, double-click the Projected Coordinate Systems folder, the Continental folder, and the North America folder. Click on North America Lambert Conformal Conic.prj. Make sure that your dialog matches the following graphic, then click Add.

The Spatial Reference Properties dialog is updated with the coordinate system details.
13 Click OK.

The coordinate system information will be written to a .prj file associated with the FastCities shapefile.

14 Click OK.

The Define Projection tool runs and you see a progress report.

15 Click Close on the progress report. Close the ArcToolbox window.

With the correct coordinate system information, ArcMap reprojects the FastCities layer into the Albers Equal Area Conic projection. The cities appear in their correct positions.
16 On the View menu, point to Bookmarks, and click Lower 48 after Projection.

You will copy the FastCities layer to the other two data frames.

17 On the View menu, click Layout View.

18 In the table of contents, right-click FastCities.lyr and click Copy.

19 In the table of contents, right-click on the Hawaii data frame and click Paste Layer(s). Again in the table of contents, right-click on the Alaska data frame and click Paste Layer(s).

Honolulu and Anchorage appear in their respective data frames.

In the Alaska data frame, the FastCities layer is reprojected to Alaska Albers Equal-Area Conic. In the Hawaii data frame, it is reprojected to Hawaii Albers Equal-Area Conic.
Your map shows which states and cities have experienced the most growth between 1990 and 2000.

If you want to save your work, click the File menu and click Save As. Navigate to C:\GTK\ArcGIS\Chapter13\MyData. Rename the file my_ex13b.mxd and click Save.

In the next chapter, you will work exclusively with ArcCatalog, so you’ll exit ArcMap now.

Click the File menu and click Exit. Click No if prompted to save your changes.