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GIS analysis projects usually begin with several data sets and the plans to process
them to get a result. When you perform an operation on spatial data that creates
anew data set {often a slightly modified version of the original), you are doing
geoprocessing. Geoprocessing tasks are accomplished with ArcToolbox™ a collec-
tion of tools that you add ro the ArcMap or ArcCatalog interface from the Standard
toolbar,

Data sets are not always in exactly the condition you need for a project. For exam-
ple, features may be either too detailed or too generalized for the map scale you are
working at. Another problem may be not having all che attributes you want. And
somerimes the problem is even one of too much data—you may have thousands of
features cluttering your area of interest or extending well beyond it.

Having too much data is, of course, a becter problem than not having enough.
ArcToolbox contains a number of tools to help you screamline data sets. You can
simplify dara by dissolving a group of features with a common attribute value into
one feature. You can trim a data set to your area of inrerest by using features in one
layer ro clip features in another. Other techniques don’t require special geoprocess-
ing tools. For example, you can work with fewer features by making a selection on a
layer and creating a new layer from it.




Dissolving features
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A dissolve creates a new layetr in which all features in an input layer that have (he
same value for a specified attribute become a single feature. In the fellowing exap.
ple, states are dissolved by sales region.

States labeled by sales region
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The new layer's attribute table has the standard geometry (Shape) and feature iden-
tifter (FID) actributes along with the actribute used in the dissolve (Region). You
can include other attribures as well. In the sales regicn example, the inpur table has
an actribute storing the number of customers per state. In the output table, rhese
values can be summed for each region.
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Exercise 1a

You work for a lumber company rhar plans to harvest timber in the Tongass National
Forest in southeastern Alaska. Forest land can be divided into stands—groups of
trees with something in common, such as type, age, or size. In a national forest,
stands can be grouped into larger areas and leased ro private companies by the U.S.

Forest Service. Restrictions are placed on logging in sensitive parts of the lease areas,
such as endangered animal habitat.

The Forest Service is presently considering leasing five adjacent areas.

Canada

The Tongass National Forest, shown in dark green, Lease areas under consideration are
covers 16,800,000 acres {about 68,000 square shown in purple.
kilometers} of the Alaska panhandle.

As your company’s GIS analyst, your job in this and the following chapter is to
calculate the timber values of the potential lease areas. Your analysis will help your
company decide how much to bid for each area.

You have a polygon layer of forest stands provided by the forest service. [es attribures
include the estimated value of each stand and the lease area each stand belongs to.

In this exercise, you'll dissolve the stands into the five lease areas. You'll total the
stand values to get a preliminary esrimate of how much each lease area is worth. In
chapter 12, you’ll refine this estimate by eliminating areas that can’t be harvested.
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F# In the table of contents, right-click on the Stands tayer and click Open Attributé
Table. '

BE Start ArcMap. In the ArcMap dialog, click the option to use an existing map. |
fist of existing maps, double-click Browse for maps. (If ArcMap is already ryp
click the File menu and click Open.) Navigate to CAGTKArcGIS\Chapter11. Cl
ex11a.mxd and click Open.
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The Stands layer has 1,405 stands, each represented by one record in the table.

The StandValue artribute contains the dollar value of each stand in millions of dollars.
It was obtained by multiplying ValuePerMeter by Shape_Area (Shape_Area stores the
size of each fearure in square meters) and then dividing by 1,000,000. The value of the
first stand, for instance, appears as 1.00353, which is just over a million dollars.




Z¥ In the ArcToolbox window, click the plus sign next to Data Management Togls -
then click the plus sign next to Generalization.
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The ArcToolhox graphics in this book assume that you are using an ArcView soft-
ware license and that you have nor installed optional extensions such as Arc(GIS
Sparial Analyst. If you have an ArcEditor or Arclnfo license, or if you have installed
extensions, your window will show additional toolboxes.

&l Double-click the Disselve tool to open the Dissolve dialog box.

Although each ool in ArcToolbox has its own functionality and sectings, all use a
similar dialog box with some common elements. For example, each tool has a Show
Help button in the lower right corner that describes the tool and its settings.

Tools with lots of settings have a scroll bar on the right. As an alternative to scroll-
ing, you can resize the dialog by dragging on a side or corner. Once you do this,




ArcToolbox remembers the new size and applies it to the next tool you open. {So if
the dimensions of your Dissolve dialog are different from the graphic, it means you
have previously resized this or some other tool. That’s ine—the dialog can be what-
ever size you like.)

The Dissolve tool requires thar you select an input layer of features to dissolve, a
location where the newly created layer will be saved to disk, and an attribute to
dissolve on.

{3 In the Input Features drop-down list, select Stands. (It's the only layer in the map.)

When you select the input features, a default path and file name appear for the output
data. The list of attributes that can be disselved on appears in the Dissolve_Field(s) box.

The output data can be saved as either a shapefile or as a geodarabase feature class.
You'll save it as a geodatahase feature class because the rest of the Tongass data is in
this format. To leave the Tongass geodatabase intact, you'll save the output to a
duplicate geodatabase called MyTongass that has been created for you.

R Click the Browse button next to the OQutput Feature Class box. In the Output
Feature Class diateg, navigate to CAGTKAreGIS\Chapter11\MyData. Double-
click on MyTongass.mdb.

Bl In the Name box, type Leases. Make sure your dialog matches the following
graphic, then click Save.




B8 In the Dissolve Field(s) box, click the LeaseiD check box.
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Each set of polygons with the same Lease[D will be dissolved inte a single feacure.

ArcMap can also summarize the accribute values of dissolved fearures by a variety of
statistics. To find out the timber value of each lease, you will summarize the Srand-
Value attribute by the Sum statistic type. This will total the values of all stands dis-

solved within a lease. (You can also get the mean, the range, the standard deviation,
and other measures of numeric attributes.)

80 In the Dissolve dialog, scrolf down to the Statistics Field(s) area. Click the
Statistics Field{s) drop-down arrow and click StandValue to add it to the list,

The field name displays in the Field column heneath the drop-down list. The red
circle with an x indicates that you still need to specify the type of statistic you want.




EEl Click the first cell in the Statistic Type column. In the drop-down list that
anpears, click SUM.

EEl Make sure your Statistics_Field(s) list matches the fotlowing graphic, then click
OK in the Dissolve dialog.

When tools run, a dialog box opens to show the progress of the operation and the !
elapsed time. Your date and time will be different.
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Executed [Dissolve 1) sweccessfully,
End Time: Wad Rar 03 D8:50:32 2004
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EEY When the operation is completed, click Close on the dialog box.

The new Leases layer is added to the map. {If you don’t see it, click the Add Data ‘
button, navigate to the MyTongass geodatabase, and add the layer. Then click the .
Tools menu and click Options. On the Opticns dialog, click the Geoprocessing tab. '
Near the bottom of the dialog, check the box to add results of geoprocessing opera-

tions to the display. Click OK. Any new geoprocessing layers will be added to ArcMap ’
automatically.)

When a new geoprocessing layer is created and added to ArcMap, 1t displays ina

random color. In many of the exercise steps in this chapter and the next, the colors
on your screen may not match the graphics in the book.

The ArcToolbox window stays open until you close it. If you exit ArcMap wirh the
window open, it will be open the next time you start ArcMap.
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Ef1 On the Standard toolbar, click the Show/Hide ArcToolpox Windeow button to
close ArcTooibox. In the table of contents, right-click the Leases layer and click
Zoom to Layer

5

T In the table of contents, right-click on the Leases layer and click Open Attribute
Table. If necessary, resize the table to show all fields.

The original 1,405 srands have been aggregated into five lease polygons.

LeaselD) is the atrribure you dissolved on. SUM_StandValue is the statistical field you
requested. It contains the sum of all stand values (in millions of dollars) in each
lease area. The value of lease A, for instance, is abour 626 million dollars.

Shape_Length and Shape_Area are measurement atrributes automatically main-

tained by ArcMap for geodatabase feature classes. (Shape_Length, for a polygon
feature class, measures feature perimeters.)

B Close the table.

EF 1f you want to save your work, click the File menu and click Save As. Navigate to
CAGTKArcGIS\Chapter1T\MyData. Rename the file my_ex11a.mxd and click Save.

E59 If you are continuing with the next exercise, leave ArcMap open. Otherwise,
click the File menu and dick Exit. Click No if prompted to save your changes.




Creating graphs

S

The ArcGIS Graph Wizard lets you create many different kinds of graphs, including
column, pie, area, and scatter graphs. You can set properties for such clements as
titles, axes, and graph markers (the bars in a bar graph, for instance). Graphs can be
saved with a map documenc or as files with a .grf extension that can be added to any
map document.

Exercise 11b

You have dissolved the forest stands into lease areas and summed their harvestable
values. In this exercise, you'll present the values in a graph and add the graph to a
map layour.

Start ArcMap. In the ArcMap dialog, click the opticn to use an existing map. In
the list of existing maps, double-click Browse for maps. {If ArcMap s already
running, click the File menu and click Open.) Navigate to CAGTKArcGIS\Chapter11.
Click ex11b.mxd and click Gpen.
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The map shows the lease areas you created in the previous exercise.




#3 Click the Tools menu, point to Graphs, and click Create.
The Graph Wizard opens.

Graph Wizaid, Step 1 of 3.

in the first panel, you'll accept the default graph type (a column graph) and subtype
(one that compares values across categories).

Click Next.

In the second panel, you choose a layer and check the attributes you want to graph.
Leases is the selected layer. In the box of attributes, Sum_StandValue is checked.
(The fult actribute name appears if you hold the mouse pointer over it.)

~m




Graph of Leases
1000

A00.
690

400
200
0

I
In the third panel, you'll change the default title and label the x-axis. (To change '
fonts, colors, and other properties, you would click Advanced Options.) As you |
make changes, the graph preview updates.

El In the Title box, replace Graph of Leases with Lease Values. In the Sub title box,
type In millions of dollars. l;

|

|

!

E# Check Label X Axis With and make sure its drop-down list is set to LeaselD.

BH Uncheck Show Legend. The LeaselD values display on the x-axis. Make sure your
dialog matches the following graphic, then click Finish.
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The graph displays in a window thar floats on the application window. The graph
makes it easy o compate the lease area values. Lease F the most valuable, is wor,
about 1.5 billion dollars.

Lease Values

A B c D ] )
In millions of dollars

You'll add the graph to the map layout.
ER Right-click on the graph title bar. On the context menu, click Show on Layout.
ArcMap switches to layout view.

E¥ Close the graph window.

Tongass Natonal Ferest
Lease Areas

The graph displays in the middle of the layout page, marked with blue selection

handies. (Other layout elements, such as the map ritle and lease labels, have been
added for you.)

Kl On the Tools tootbar, make sure the Select Elements tool is selected.




Efl Drag the graph to the upper right corner of the layout, as shown in the
foliowing graphic. Click outside the Jayout page to unselect the graph.

Tongyass Natonal Forest Lezce \aobues
Lease Areas

[l Close the Layout toolbar.

B If you want to save your work, click the File menu and click Save As. Navigate to
CAGTKArcGIS\Chapter1 T\MyData. Rename the file my_ex11b.mxd and click Save.

If you are continuing with the next exercise, leave ArcMap open. Otherwise,
click the File menu and click Exit. Click No if prompted to save your changes.




T

ot

Clipping layers

Clipping trims features in one layer using the boundaries of polygon features from
another layer. [t's like having a pair of scissors, or a cookie cutter, to cut away dypg
that vou don’t need for your project. For example, you might have a shapefile of al
the streets in your county, while your study area encompasses just one ZIP Code
within that county. If you have a polygon feature representing that ZIP Code, you
can use it to clip out just the streets you need. Clipping can be a matter of conve.
nience—since smaller data sets are easier to process—but it can also be importag,
for analysis. To find out the total length of roadway within the ZIP Code, for
instance, you must exclude streets and street segments that lie outside it.

[n the tollowing example, a layer of interstate highways is clipped at the boundaries
of the state of Oklahoma.

™ Mwa-ﬂ

Input layer of U.S. interstate highways Highways clipped at
and clip layer of Oklahoma polygen boundary

Exercise T

The forest service has just determined that, of the five lease areas, only lease Fis

mature enough for harvest. Your company will direct its attention to making a bid
for this lease.

Naot every square meter of the lease area is harvestable. Logging is prohibited near
streams and goshawk nests. (Goshawks are a protected bird species.) You have layers
of streams and goshawk nests that cover all five lease areas, but now you'd like w
work with data sets that cover only the area of lease E

In this exercise, you'll clip a layer of streams to the boundary of lease E

' CHAPTERI1 ¢ PREPARING DATA FOR ANA
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Start ArcMap. In the ArcMap dialog, dick the option to use an existing map. In
the list of existing maps, double-click Browse for maps. (if ArcMap is already
running, click the File menu and click Open.) Navigate to CAGTKArcGIS\Chapter1t.
Click ex1t1camxd and ¢lick Open.

The map displays the five lease areas and a Streams layer that contains 1,566 stream
segments.

To clip the streams to the lease F boundary, you must first select lease F You'll turn J
the selection into a new layer so you can look ar lease F apart from the others.

EX Click the Selection menu and click Set Selectable Layers. Uncheck Streams, as
shown in the foilowing graphic, then click Close.




¥ On the Tools toolbar, click the Select Features tool.

R

’

B Inthe table of contents, right-click on the Leases layer, point to Selection, and
click Create Layer From Selected Features.
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A layer called Leases selection is added to the top of the table of contents. This
layer references the same geodarabase feature class as the Leases layer. Unlike
geoprocessing operations, creating a selection layer doesn’t create a new data set.

PTER 11 ® PREPARING DATA E¢




(You can, however, export a selection layer, or a set of selected features, as a new
data set if you want to, You will do this in the next exercise.)

Make sure the Display tab is selected in the table of contents. Turn off the Leases
layer and drag the Leases selection {ayer to the bottom of the table of contents.

B Steams
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You'll use the ArcToolbox Clip tool to clip the streams to the boundary of lease F
On the Standard toclbkar, dick Show/Hide ArcToolbox Window.

In the ArcToolbox window, click the plus sign next to Analysis Tools. Click the
plus sign next to Extract.
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Double-click the Clip toot.

You'll select the layer with the input features to be clipped, the layer to clip with,
and an output feature class. As with Dissolve, the output of a clip can be cither a
shapefile or a geodarabase feature class. You will add the clipped streams to the
MyTongass geodatabase.

E0T In the Input Features drop-down list, click Streams. In the Ciip Features drop-
down list, click Leases selection.

iR Click the Browse button next to the Output Feature Class drop-down list. In the

Cutput Feature Class dialog, navigate to CAGTKArcGIS\Chapter11\MyData and
double-click on MyTongass.mdb,

¥ In the Name box, type StreamsF. Make sure your dialog malches the following
graphic, then dick Save.
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The Clip rool’s progress report lists each operation and the elapsed time.

EES When the operation is completed, click Close on the dialog box. in the table of
contents, turn off the Streams layer.
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The StreamsF layer, consisting of stream features clipped to the boundary of Jeg
is added to rhe map.

Close the ArcToolbox window.

15
£ In the tahle of contents, right-click on the StreamsF layer and click Open
Attribute Table.
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The Clip operation has reduced the number of stream segments from 1,566 (in the
Streams layer) to 358. The table has attributes that will determine how much area

around the streams is off-limirs to logging. You will work with these attributes in the
next chapter.

Close the table.

If you want to save your work, click the File menu and click Save As. Navigate to
CAGTKArcGIS\Chapter11\MyData. Rename the file my_ex11c.mxd and click Save,

If you are continuing with the next exercise, leave ArcMap open. Ctherwise,
click the File menu and click Exit. Click No if prompted to save your changes.




Exporting data

Operations like Dissolve and Clip create new data sets automatically. Another way
to make a new data set from an existing one is to make a selection on a layer and
export the selected features.

Exercise 11d

In addition to the streams layer, you have a layer of goshawk nests coveting all five
lease areas. You could clip this layer just as vou did the streams. Unlike the streams,
however, the nests are points and thecefore don’t cross polygon boundaries. (In the
map it will look as if they do, bur that is an effect of symbology.) Because nests are
contained within polygons, you can use Select By Location to select the nests in
lease F and then export the selected ser.

BE Start ArcMap. in the ArcMap dialog, click the option to use an existing map. in
the list of existing maps, double-dick Browse for maps. (If ArcMap is already
running, click the Fiie menu and click Open.) Navigate to CAGTKArcGIS\Chapter11.
Click ex11d.mxd and click Cpen.
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The map contains a layer of goshawk nests and a layer of lease E




8 Click the Selection menu and click Select By Location. If necessary, click the
selection method drop-down arrow and click “select features from.”

Select By Location 7

In the box cof layers to select from, check GoshawkNests.

in the drop-down list of spatial relationships, click "are contained by.”

B In the drop-down list of layers, click LeaseF. Make sure your dialog matches the
following graphic, then click Apply.
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E# Click Close on the dialog. In the ArcMap table of contents, right-click the
GoshawkNests fayer, point to Data, and click Export Data.

The Export drop-down list is correctly set ro Selecred features. The option o use
the same coordinare system as the layer’s source data is also correct. (You'll learn
more about coordinate systems in chapter 13.)

EE Click the Browse button next to the Qutput shapefile or feature class box.

ER In the saving Data dialog, make sure the Save as type drop-down list is set to
Personal Geodatabase feature classes. If necessary, navigate to CAGTKArcGIS
‘Chapter11\MyData and double-click on MyTongass.mdb,

ER In the Name box, replace Export_Cutput with NestsE Make sure your dialog
matches the following graphic, then click Save.
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B Click OK in the Export Data dialeg.

ArcMap exports the selected nests to a new feature class and prompts you to add
data to the map.
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You don'’t see the point features of the new NestsE iayer because they are covered by .
the selection highlights on the GoshawkNests layer.

i in the table of contents, turn off the GoshawkNests layer.




The new layer contains only goshawk nests within Jease F The defauit symbol is not
as informative as the one in the GoshawkNests layer.

EE] In the tabie of contents, double-click on the NestsF layer. In the Layer Properties
dialog, click the Symbolegy tab and click Import.

You want to import symbology from another layer in the map, so the first opticon is
set correctly. The Layer drop-down list is also correcrly set.

Click OK.




EH Click OK in the Layer Properties dialog. ) Sl
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You have prepared the data for your analysis. In the next chapter, you'll create
exclusion zones around the streams and goshawk nests in lease E You'll use these
zones to figure out how much timberland in the lease area is harvestable and how
much it’s worth.

B If you want to save your work, click the File menu and click Save As. Navigate to
CAGTKArcGIS\Chapter11\MyData. Rename the file my_ex11d.mxd and click Save,

§E 1 you are continuing to the next chapter, leave ArcMap open. Otherwise, dick
the File menu and click Exit. Click No when prompted to save your changes.




